Continuano le mie sperimentazioni con Arduino, non senza difficoltà. Avendo avuto fin dall'inizio problemi con i sensori di temperatura DS18B20 ne ho fatto una piccola scorta e dopo essere arrivato al punto descritto nel mio precedente post  ho pensato di aggiungere ulteriori sensori al mio progetto e qui continuano i dolori perché continuo ad avere funzionamenti irregolari. Non sono riuscito a far funzionare più di cinque sensori sulla stessa linea, allora ho pensato di fare due "bus", sfruttando l'ultima uscita digitale rimasta libera sul mio Arduino. Per qualche giorno ha funzionato, poi qualche sera fa ho fatto una piccola modifica (neanche ricordo quale) e si è "rotto" tutto. Questa sera ho cercato di fare una diagnosi approfondita, ne è risultato che alla seconda chiamata  "sensors2.begin();" che viene fatta per inizializzare i sensori su un bus 1-wire nella parte di setup dello sketch arduino, questo si resettava, andando di fatto in loop sulla parte di setup. Qui c'è l'ultimissima versione dello sketch che ho installato, rispetto alle versioni precedenti è largamente rimaneggiata nel disperato tentativo di recuperare memoria e risolvere il mio problema che pensavo dovuto a scarsità di ram, cosa che però non sembra essere. In questa versione dello sketch ho anche provato a invertire le chiamate "begin" dei due bus 1-wire, senza risultato, nel senso che alla seconda chiamata qualunque fosse il bus Arduino si resettava impietosamente.

Poi è successa una delle cose che mi fanno impazzire: ho inserito nella libreria DallasTemperature.cpp dentro il metodo setup un "Serial.println()" e miracolosamente tutto ha iniziato a funzionare, non so per quanto.

JSN Corsa template designed by JoomlaShine.com

We use cookies to improve our website and your experience when using it. Cookies used for the essential operation of this site have already been set. To find out more about the cookies we use and how to delete them, see our privacy policy.

  I accept cookies from this site.
EU Cookie Directive Module Information